阅读

webpack运行Babel教程

摘要: Babel是转码器,webpack是打包工具,它们应该如何一起使用呢?



ES6 + IE10 = 语法错误!

test.js使用了ES6的箭头函数

setTimeout(() =>
{
console.log("Hello, Fundebug!");
}, 100)

由于低版本的浏览器没有支持ES6语法,这就意味着代码会出错。例如,在IE 10浏览器中,会出现”语法错误”:



如果你使用了Fundebug错误监控服务,则会收到这样的报错:



直接使用babel转码

当你使用更高版本的JavaScript语法时,比如ES7,低版本的浏览器将无法运行。为了兼容低版本的浏览器,比如万恶的IE,我们不得不使用Babel,将ES6、ES7等高版本代码转换为ES5代码。

安装babel-cli

sudo npm install --global babel-cli

使用babel命令转码

babel test.js --out-file compiled.js

转码之后生成的代码为compiled.js

setTimeout(function () {
console.log("Hello, Fundebug!");
}, 100);

可知,箭头函数转换成了function,这样就代码可以在IE 10等不支持ES6的浏览器上正确执行了。

广告:欢迎免费试用Fundebug,助您第一时间发现代码BUG。

使用webpack运行Babel

一般项目中都会使用webpack对代码进行打包,比如,将多个js文件打包成1个js文件,这样可以减少前端的资源请求。因此,我们需要将Babel也集成到webpack中。

安装webpack

npm install --global webpack

我使用的webpack版本为4.10.0

webpack --version
4.10.0

安装babel

npm install --save-dev babel-cli babel-preset-env

babel-preset-env是Babel新版的preset,它可以让我们灵活地设置代码目标执行环境,比如只支持各个浏览器最新的2个版本,支持IE8及其以上的IE浏览器。

安装babel-loader

npm install --save-dev babel-loader

babel-loader是webpack的babel插件,它让我们可以在wepback中运行Babel。

配置babel

新增.babelrc文件:

{
"presets": ["env"]
}

配置webpack

新增webpack.config.js文件:

module.exports = {
entry: './test.js',
output:
{
path: __dirname,
filename: 'bundle.js'
},
module:
{
rules: [
{
test: /\.js$/,
exclude: /node_modules/,
loader: 'babel-loader'
}]
}
};

可知,我们在webpack中使用了babel-loader插件来运行Babel,转换所有的.js代码(除了node_modules中的代码)。

使用webpack运行babel

webpack --mode production

转换之后的代码为bundle.js。bundle.js只有1行代码,这是因为为我们指定的mode为production,webpack为了压缩代码只生成了1行代码。

参考

关于Fundebug

Fundebug专注于JavaScript、微信小程序、微信小游戏、支付宝小程序、React Native、Node.js和Java实时BUG监控。 自从2016年双十一正式上线,Fundebug累计处理了6亿+错误事件,得到了Google、360、金山软件等众多知名用户的认可。欢迎免费试用!




您的用户遇到BUG了吗?

体验Demo 免费使用